Browse Source

Upgrade JS SDK to 5.0.0-rc.1 and React SDK to 2.1.0-rc.2

pull/12374/head
RiotRobot 2 years ago
parent
commit
35204416bf
  1. 8
      package.json
  2. 17
      yarn.lock

8
package.json

@ -66,8 +66,8 @@
"gemini-scrollbar": "github:matrix-org/gemini-scrollbar#91e1e566",
"gfm.css": "^1.1.2",
"highlight.js": "^9.13.1",
"matrix-js-sdk": "github:matrix-org/matrix-js-sdk#develop",
"matrix-react-sdk": "github:matrix-org/matrix-react-sdk#develop",
"matrix-js-sdk": "5.0.0-rc.1",
"matrix-react-sdk": "2.1.0-rc.2",
"olm": "https://packages.matrix.org/npm/olm/olm-3.1.4.tgz",
"postcss-easings": "^2.0.0",
"prop-types": "^15.7.2",
@ -191,7 +191,9 @@
"afterSign": "scripts/electron_afterSign.js"
},
"jest": {
"modulePathIgnorePatterns": ["<rootDir>/electron_app"],
"modulePathIgnorePatterns": [
"<rootDir>/electron_app"
],
"testEnvironment": "jest-environment-jsdom-fourteen",
"testMatch": [
"<rootDir>/test/**/*-test.js"

17
yarn.lock

@ -7595,9 +7595,10 @@ mathml-tag-names@^2.1.1:
resolved "https://registry.yarnpkg.com/mathml-tag-names/-/mathml-tag-names-2.1.1.tgz#6dff66c99d55ecf739ca53c492e626f1d12a33cc"
integrity sha512-pWB896KPGSGkp1XtyzRBftpTzwSOL0Gfk0wLvxt4f2mgzjY19o0LxJ3U25vNWTzsh7da+KTbuXQoQ3lOJZ8WHw==
"matrix-js-sdk@github:matrix-org/matrix-js-sdk#develop":
version "4.0.0"
resolved "https://codeload.github.com/matrix-org/matrix-js-sdk/tar.gz/21e4c597d9633aef606871cf9ffffaf039142be3"
matrix-js-sdk@5.0.0-rc.1:
version "5.0.0-rc.1"
resolved "https://registry.yarnpkg.com/matrix-js-sdk/-/matrix-js-sdk-5.0.0-rc.1.tgz#75a48d999b2eecdbfcc000e05123a00ae80039a7"
integrity sha512-g4b7Zf2Ws+yUnRCetpMqCSpesnRu0I+wAvFUYdoKhEGzSihEs6qADvV880Twcun1YFxYBjdB9I7ZfzCkGsi4Lw==
dependencies:
"@babel/runtime" "^7.8.3"
another-json "^0.2.0"
@ -7617,9 +7618,10 @@ matrix-mock-request@^1.2.3:
bluebird "^3.5.0"
expect "^1.20.2"
"matrix-react-sdk@github:matrix-org/matrix-react-sdk#develop":
version "2.0.0"
resolved "https://codeload.github.com/matrix-org/matrix-react-sdk/tar.gz/805e9abb3981584cd941e59c5c10edc3595c38b9"
matrix-react-sdk@2.1.0-rc.2:
version "2.1.0-rc.2"
resolved "https://registry.yarnpkg.com/matrix-react-sdk/-/matrix-react-sdk-2.1.0-rc.2.tgz#3cf74ca9af7e99931668002c78bc31b59717d61c"
integrity sha512-5pc8CgmkUZC95Y2eyVBexcy+Avu/qRtTk9nM7SBhHCV9lXpXjDnSSIxfgI9cYavNbJhV63bBFEUjAWd0SMZzGQ==
dependencies:
"@babel/runtime" "^7.8.3"
blueimp-canvas-to-blob "^3.5.0"
@ -7647,7 +7649,8 @@ matrix-mock-request@^1.2.3:
is-ip "^2.0.0"
linkifyjs "^2.1.6"
lodash "^4.17.14"
matrix-js-sdk "github:matrix-org/matrix-js-sdk#develop"
matrix-js-sdk "5.0.0-rc.1"
minimist "^1.2.0"
pako "^1.0.5"
png-chunks-extract "^1.0.0"
prop-types "^15.5.8"

Loading…
Cancel
Save