Add transform-async-to-bluebird

Add babel plugin until the js-sdk stop using bluebird, since we
force-recompile the js-sdk so we need the plugin installed for that
to work (and it's a devDependency on js-sdk so doesn't otherwise get
installed).
release-v1.5.6
David Baker 3 years ago
parent c99cd9fc58
commit 577e614fa4
  1. 1
      package.json
  2. 16
      yarn.lock

@ -64,6 +64,7 @@
"test-multi": "karma start"
},
"dependencies": {
"babel-plugin-transform-async-to-bluebird": "^1.1.1",
"babel-polyfill": "^6.26.0",
"babel-runtime": "^6.26.0",
"browser-request": "^0.3.3",

@ -919,7 +919,7 @@ babel-helper-explode-class@^6.24.1:
babel-traverse "^6.24.1"
babel-types "^6.24.1"
babel-helper-function-name@^6.24.1:
babel-helper-function-name@^6.24.1, babel-helper-function-name@^6.8.0:
version "6.24.1"
resolved "https://registry.yarnpkg.com/babel-helper-function-name/-/babel-helper-function-name-6.24.1.tgz#d3475b8c03ed98242a25b48351ab18399d3580a9"
integrity sha1-00dbjAPtmCQqJbSDUasYOZ01gKk=
@ -1081,6 +1081,16 @@ babel-plugin-transform-async-generator-functions@^6.24.1:
babel-plugin-syntax-async-generators "^6.5.0"
babel-runtime "^6.22.0"
babel-plugin-transform-async-to-bluebird@^1.1.1:
version "1.1.1"
resolved "https://registry.yarnpkg.com/babel-plugin-transform-async-to-bluebird/-/babel-plugin-transform-async-to-bluebird-1.1.1.tgz#46ea3e7c5af629782ac9f1ed1b7cd38f8425afd4"
integrity sha1-Ruo+fFr2KXgqyfHtG3zTj4Qlr9Q=
dependencies:
babel-helper-function-name "^6.8.0"
babel-plugin-syntax-async-functions "^6.8.0"
babel-template "^6.9.0"
babel-traverse "^6.10.4"
babel-plugin-transform-async-to-generator@^6.24.1:
version "6.24.1"
resolved "https://registry.yarnpkg.com/babel-plugin-transform-async-to-generator/-/babel-plugin-transform-async-to-generator-6.24.1.tgz#6536e378aff6cb1d5517ac0e40eb3e9fc8d08761"
@ -1503,7 +1513,7 @@ babel-runtime@^6.0.0, babel-runtime@^6.18.0, babel-runtime@^6.2.0, babel-runtime
core-js "^2.4.0"
regenerator-runtime "^0.11.0"
babel-template@^6.24.1, babel-template@^6.26.0, babel-template@^6.3.0:
babel-template@^6.24.1, babel-template@^6.26.0, babel-template@^6.3.0, babel-template@^6.9.0:
version "6.26.0"
resolved "https://registry.yarnpkg.com/babel-template/-/babel-template-6.26.0.tgz#de03e2d16396b069f46dd9fff8521fb1a0e35e02"
integrity sha1-3gPi0WOWsGn0bdn/+FIfsaDjXgI=
@ -1514,7 +1524,7 @@ babel-template@^6.24.1, babel-template@^6.26.0, babel-template@^6.3.0:
babylon "^6.18.0"
lodash "^4.17.4"
babel-traverse@^6.24.1, babel-traverse@^6.26.0:
babel-traverse@^6.10.4, babel-traverse@^6.24.1, babel-traverse@^6.26.0:
version "6.26.0"
resolved "https://registry.yarnpkg.com/babel-traverse/-/babel-traverse-6.26.0.tgz#46a9cbd7edcc62c8e5c064e2d2d8d0f4035766ee"
integrity sha1-RqnL1+3MYsjlwGTi0tjQ9ANXZu4=

Loading…
Cancel
Save