Browse Source

Remove babel-polyfill

Should be no need for it if we're using transform-runtime (and
we definitely don't need it twice...)
pull/2461/head
David Baker 6 years ago
parent
commit
64815b1b0b
  1. 2
      package.json
  2. 4
      src/vector/index.js

2
package.json

@ -36,7 +36,6 @@
"test:multi": "karma start"
},
"dependencies": {
"babel-polyfill": "^6.5.0",
"babel-runtime": "^6.11.6",
"browser-request": "^0.3.3",
"classnames": "^2.1.2",
@ -67,7 +66,6 @@
"babel-eslint": "^6.1.0",
"babel-loader": "^6.2.5",
"babel-plugin-transform-runtime": "^6.15.0",
"babel-polyfill": "^6.5.0",
"babel-preset-es2015": "^6.16.0",
"babel-preset-es2016": "^6.16.0",
"babel-preset-es2017": "^6.16.0",

4
src/vector/index.js

@ -16,10 +16,6 @@ limitations under the License.
'use strict';
// for ES6 stuff like startsWith() that Safari doesn't handle
// and babel doesn't do by default
require('babel-polyfill');
// CSS requires: just putting them here for now as CSS is going to be
// refactored soon anyway
require('../../vector/components.css');

Loading…
Cancel
Save