Don't try to build with node 6.0

because it has broken npm
pull/4145/head
Richard van der Hoff 5 years ago
parent e868dbbb94
commit 71aed70d4b
  1. 6
      .travis.yml
  2. 4
      README.md

@ -9,7 +9,11 @@ node_js:
# - 7.x is the current 'current' version (until October 2017)
#
# see: https://github.com/nodejs/LTS/
- 6.0
#
# anything before 6.3 ships with npm 3.9 or earlier, which had problems
# with symlinks in node_modules (see
# https://github.com/npm/npm/releases/tag/v3.10.0 'FIXES AND REFACTORING').
- 6.3
- 6
- 7
install:

@ -55,8 +55,8 @@ Building From Source
Riot is a modular webapp built with modern ES6 and requires a npm build system
to build.
1. Install or update `node.js` so that your `node` is at least v6.0.0 (and `npm`
is at least v3.8.6).
1. Install or update `node.js` so that your `node` is at least v6.3.0 (and `npm`
is at least v3.10.x).
1. Clone the repo: `git clone https://github.com/vector-im/riot-web.git`.
1. Switch to the riot-web directory: `cd riot-web`.
1. If you're using the `develop` branch, install the develop versions of the

Loading…
Cancel
Save